VIVE討論
瀏覽 : 12035
分享

[分享] Vive無線模組問題排除心得:定時黑畫面、Vrchat控制器失效

一般用戶

等級1

路過旅人

文章分類:VIVE / VIVE 官方配件

DSS2021-6-3 21:08

Vive無線模組在某次SteamVR大改版之後,有不少玩家發生只要啟動5至10分鐘,
VIVE就會黑畫面,透過耳機和螢幕可以判斷聲音和定位功能是正常的,
之前我的解法是先跑別的遊戲,發生黑畫面之後拔電重插再去玩真的想要玩的遊戲,
但是我現在遇到的狀況是有些遊戲這樣解會定位錯誤,
所以找了很久..華語圈完全沒有解答,找到了英文的。

解法是:把控制器閒置5分鐘自動關機關掉


插圖2.jpg


插圖3.jpg



......聽起來很低能,但是真的就是這樣= =


第二個問題,VRChat裡面控制器不見了,
就是VRCHAT裡面動態手把沒有作用,可是可以呼叫SteamVR系統,
有些人會遇到,會查到說把STEAMVR控制器的定義改一下怎樣地,
然後你就會卡在STEAMVR改版之後那些功能找不到了。
我也試過砍掉快取、甚至整個VRCHAT、整個STEAMVR重裝都沒用,
我最後是手賤去點了ViveWirelessSetup.exe
對,我重裝了一次無線模組的程式
然後VRCHAT的控制器都回來了。


如果你和我一樣使用VIVE無線模組,不論你的頭盔是VIVE PRO或是COSMOS,
如果有遇到這兩個問題,或許可以幫上忙。


檢舉 回應

一般用戶

等級1

路過旅人

betavive2021-6-4 17:18

SteamVR 1.17



Vive Pro:


  • Fixed SteamVR crash when using room view over Vive Pro wireless adapter.

檢舉 回應

一般用戶

等級1

路過旅人

samho2021-6-24 20:58

這招對我的狀況無效(隨機斷掉再重新連線),我原本以為是無線模組溫度過高的問題,不過我觀察最近幾次斷掉自動重啟的 log 檔,有時溫度還不到70度就直接斷掉重開

(直接出現 USB node not found 1.)

看 reddit 的討論,有一個不小的機會會是原廠的 USB 線不穩;問題是這條線必需是可以跑 QC 3.0 需要的電流 又得是 USB Type A 公對公的....簡單的說,市面上根本沒剛好這個規格的線( QC 3.0 的找得到的都 Type-A 公對 Type-C 公, Type-A 公對公的幾乎都沒標示電流 或是直接給你 USB 2.0 的電流)。


官方有機會/打算賣這種特規的線嗎?


檢舉 回應

一般用戶

等級1

路過旅人

supernoodle2021-7-4 23:07

我也有定時黑畫面的狀況(有線COSMOS),目前重灌過VIVE還有Steam VR也未見改善,顯卡驅動也更新了,但是我不是用無線模組而是跟樓上一樣是接原廠的連接線也有這種狀況,根本無法正常使用......我也來試試看把自動省電的功能都關掉看看。

檢舉 回應

一般用戶

等級1

路過旅人

supernoodle2021-7-6 00:24

supernoodle 發表於 2021-7-4 23:07
我也有定時黑畫面的狀況(有線COSMOS),目前重灌過VIVE還有Steam VR也未見改善,顯卡驅動也更新了,但是我不 ...

嘗試樓主的做法還是沒用,基本上每次黑畫面前會同時發生以下現象1.steam VR 雙手的控制器會先顯示斷線 2.VIVE 控制畫面顯示USB斷線
看起來真的很像是程式上的BUG,反正每次有BUG過幾個禮拜就會慢慢修復,直覺告訴我是VIVE跟SteamVR的衝突造成......

檢舉 回應

一般用戶

等級1

路過旅人

supernoodle2021-7-6 00:36

samho 發表於 2021-6-24 20:58
這招對我的狀況無效(隨機斷掉再重新連線),我原本以為是無線模組溫度過高的問題,不過我觀察最近幾次斷掉自 ...

我因為有兩組VIVE,有交叉換過線,似乎不太像硬體問題,隔壁棚COSMOS ELITE 也類似症狀,反正就跟疫苗一樣,應該會先把Pro2 、 Focus3 先穩住,最後才會來調整舊型機,只能先耐心等等吧?先讓工程師填飽肚子以後才會有HTC繼續揉拧我們。

檢舉 回應

一般用戶

等級1

路過旅人

otis1232022-9-22 17:22

感謝您的解決方案,我已按照指示完成,並且工作正常 among us

檢舉 回應

一般用戶

等級1

路過旅人

cantona2022-10-13 14:54

This is a great idea, it will definitely be shared widely, thanks for sharing it with us run 3

檢舉 回應

一般用戶

等級1

路過旅人

Mathew232022-10-31 11:52

Try these remedies if you discover that your headset doesn't function or powers on at all when the Vive wireless is installed.
Ensure that the USB cord is inserted into the battery while using the Vive Wireless adapter.
Ensure that the Vive headset is connected to the Vive Wireless adaptor using all three cords.
A charged battery should be present. To check, fnf press the button on it.
To turn them both on, press the button on the battery first, then the button on the Vive Wireless Adapter.

檢舉 回應


分享